Casa table browser will not open. [SOLVED]

stucky
Posts: 3
Joined: Mon Jun 17, 2013 3:51 pm

Casa table browser will not open. [SOLVED]

Postby stucky » Mon Jun 17, 2013 4:13 pm

I am running CASA on a Mac OS X Version 10.6.8. I've been using it for a couple of weeks now and only recently the table browser has stopped working. I'll try opening it in the terminal using the casabrowser command. The gui window opens up just fine, then several seconds later it crashes and the Mac OS pops up with a standard error window that says, "CASA Table Browser quit unexpectedly." It asks me if I would like to Ignore, Report, or Reopen. Reopening just repeats the error. I experience the same problem when I attempt to start the browser from within CASA using browsetable. Giving the task a tablename does not stop the error from occuring.

I ran the browsetable task after setting the log filter to DEBUG2. Attached below is the resulting output in the logger. I hope it'll help.

Code: Select all

2013-06-17 20:12:41 INFO default    #######  Setting values to default for task: browsetable  #######
2013-06-17 20:12:59 INFO3 utils   Setting constraints ...Constraints set.
2013-06-17 20:12:59 INFO3 browsetable   Verifying arguments....verified.
2013-06-17 20:12:59 INFO3 browsetable   Setting constraints ...Constraints set.
2013-06-17 20:12:59 INFO browsetable      
2013-06-17 20:12:59 INFO browsetable   ##########################################
2013-06-17 20:12:59 INFO browsetable   ##### Begin Task: browsetable        #####
2013-06-17 20:12:59 INFO browsetable   browsetable(tablename="",mightedit=False,sortlist="",taql="",
2013-06-17 20:12:59 INFO browsetable           skipcols="")
2013-06-17 20:12:59 INFO browsetable   No table opened.
2013-06-17 20:12:59 INFO browsetable   Spawning table browser one moment...
2013-06-17 20:12:59 INFO browsetable   Table rendered
2013-06-17 20:12:59 INFO browsetable   No table opened.
2013-06-17 20:12:59 INFO browsetable   ##### End Task: browsetable          #####
2013-06-17 20:12:59 INFO browsetable   ##########################################


My initial idea is to simply reinstall CASA. Has anyone experience this error? What might be going wrong? I apologize for the lack of details, I wish the error messages was less vague.

Thanks for any help you can provide!
Last edited by stucky on Wed Jun 19, 2013 2:57 pm, edited 1 time in total.

Tags:

stucky
Posts: 3
Joined: Mon Jun 17, 2013 3:51 pm

Re: Casa table browser will not open.

Postby stucky » Wed Jun 19, 2013 2:56 pm

This problem has been solved with the help of a unix wise staff member. In case anyone has a similar problem, it probably means your .casa directory in your home directory has been corrupted, as was the case with mine. Move/rename the .casa directory and casabrowser will open again; however, there may be some data loss (i.e. my modified Observatories table was overwritten with the unmodified version and I had to reenter my custom observatories).


Return to “CASA”

Who is online

Users browsing this forum: No registered users and 1 guest