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Accessing the OPT and its Suite of Tools
Register at

 https://my.nrao.edu 

For this event, login to
https://opt-extra-3.aoc.nrao.edu/opt  

• This is a special version of the OPT for this 
Community Days event.

• Do not use this link to prepare and submit VLA 
observations.

https://my.nrao.edu
https://opt-extra-3.aoc.nrao.edu/opt
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Observational Considerations
The VLA primarily uses dynamic scheduling, therefore it is 
difficult to know at what exact time your project will be observed.
• Each scheduling block (SB) must include a range of 

scheduling constraints:
– LST start range
– Weather

• wind
• atmospheric phase limit (APL)

• Anticipate: 
– Unknown position of the antennas at the start 

• overhead of start-up slew time
• cable wrap request

– Availability of calibrators/slew for different starting times
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Observational Considerations
• Where are my calibrators and target sources on the sky?

• Strong, point-like calibrators are good for bandpass and delay 
calibration.

• Nearby calibrators are good for complex gain calibration 
(amplitude and phase).

• Reference pointing calibrators should be in the same general 
region of the sky.

• What are the choices for a flux density calibrator?

• Can certain calibrations be combined with fewer calibrator 
sources, i.e., use the flux density calibrator as the bandpass 
calibrator?
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Designing a Scheduling Block (SB)
• Determine which/what

– Sources to observe, and for how long (with each resource)
– Resources (Instrument Configurations):

• For Continuum
• For Spectral Line

– Calibrations to perform:
• Reference Pointing (mainly for high frequency)
• Flux Density Scale
• Delay
• Bandpass
• Complex Gain (amplitude and phase)
• Polarization (when applicable)
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What are we observing?
• Target source: the AGB star IRC+10216

• RA (J2000) = 09h 47m 57.382s
• DEC (J2000) = +13d 16’ 40.66”

• D-configuration 
• 3 hour long scheduling block

• Ka-band spectral line setup
• HC3N (νo= 36.39232 GHz)
• SiS (νo= 36.30963 GHz) 
• V (radio, LSR) = -26 km/s 
• ΔV ~ 35 km/s
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Differences to Note

The recommended reference pointing strategy since the 
observation of IRC+10216 in April 2010 has changed. 

• The data taken for the IRC+10216 Spectral Line CASA 
tutorial used a C-band reference pointing resource.

๏ X-band reference pointing is the recommended and 
preferred resource. This will slightly change the source 
selection and SB setup from the original dataset.
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Workflow

• Observer creates a 
resource catalog of 
proposed instrument 
configuration(s). 

• Create custom 
continuum or spectral 
line resources or save 
default resources to 
the catalog for easy 
access.

๏ Catalog of proposed 
source(s) are created 
during import. 

• Observer can add 
calibrators to this 
catalog for easier 
access during SB 
creation.

๏ Project tree is 
created during 
import. 

• SBs are created under 
a Program Block. The 
SBs contain scans 
which are defined by 
sources, resources, 
scan mode, and scan 
intents.

SCT 
Source 

Catalog Tool

OPT 
Observation 

Preparation Tool

RCT 
Resource 

Catalog Tool

Step 1 Step 2 Step 3
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Interactive Slides

Interactive slides will be denoted with color bars at the 
top of the slide. 

Interactive

Interactive

Interactive
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Step 1   Source Catalog Tool

• Starting with a pre-made Source Catalog: 
• Verify the science target positions were imported 

correctly.

• Starting without a pre-made Source Catalog: 
• Create a new Catalog and add the science target(s). 

• In both cases, may add the appropriate calibrators to the 
catalog:
• complex gain, flux density, bandpass, delay, reference 

pointing, etc.
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Login to the Observation Preparation Tool
Interactive
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Step 1   Accessing the Source Catalog Tool

In the OPT: click on Sources

Interactive
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Step 1   Create a Source Catalog
File → Create New → Catalog

1

2 3

Interactive
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Step 1   Edit the New Source Catalog

Provide a name for the catalog

Share the catalog 
with co-authors

Interactive
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Step 1   Create a Source in the Source Catalog
File → Create New → Source

1

2

3

Select the Catalog you will 
be creating the source in.

Interactive
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Step 1   Edit the Source Name and J2000 Position

Target source:
IRC+10216 

RA (J2000) 
09:47:57.382

DEC (J2000) 
+13:16:40.66

Interactive
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Step 1   Source LST range at the VLA

8° hard EL 
limit of the 
antennas

05:40−13:50 LST
30° < EL < 80° 

(EL limits recommended for high frequency observing 
in D-configuration to avoid antenna shadowing)

Interactive
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Step 1   Determine & Select Calibrators

• What calibrators are needed?
• Complex Gain (amplitude and phase)
• Flux Density Scale
• Bandpass
• Delay
• Reference Pointing in X-band (within 10°)

Target source: IRC+10216
RA (J2000): 09h 47m 57.382s
DEC (J2000): +13d 16’ 40.66”
LST range: 05:40−13:50
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Step 1   Finding a Complex Gain Calibrator

Click on the Sky Map icon for a Bullseye 
view of the nearby calibrators. Select the 

Catalog to 
view the 
source list.

Interactive
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Finding a Complex Gain Calibrator (Bullseye view)
J0954+1743 is appropriate for both complex gain and 
reference pointing (X-band flux density is ≥ 0.3Jy)

Step 1
Interactive
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Step 1   Advanced Search: Cone Search

1

2

3
4
5

6

7

Enter target source coordinates (09:47:57.382, 13:16:40.66) to 
search for an appropriate phase calibrator.

Select VLA, to access the 
calibrator catalog.

Interactive
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Step 1   Cone Search Results

Hover mouse 
over Details for 
Flux / Structure 
information.

Interactive
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Step 1   Copy Calibrator from VLA Catalog
Edit → Copy → Sources

1

2

3
4

Interactive
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Step 1   Paste Calibrator to Your Source Catalog
Edit → Paste → Sources

1

2

3

4

These copy/paste steps can be 
used for other calibrators.

Interactive
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Step 1   Advanced Search for Bandpass Calibrator

3

4
5

6

Search By Flux Density

2

1

Keep Cone Search selected with target 
source coordinates entered and a 50d 
search radius.

Interactive
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Step 1   Bandpass Calibration Search Results

Click on icon for 
source information.

J1229+0203 is a good bandpass and delay calibrator candidate, 
but not appropriate for X-band reference pointing.

Interactive
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Step 1   Images Tab:  Check LST Range
J1229+0203 LST range falls within the LST range of IRC+10216.

08:55−16:00 LST (30° < EL < 80°)

Interactive
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Step 1   Bandpass/Delay Cal Reference Pointing

J1224+0330 is an appropriate X-band reference pointing source for J1229+0203.
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Step 1   Choose a Flux Density Calibrator
Choose from one of the standard VLA flux density scale calibrators.

3C286 and 3C48 are recommended for high frequency observing

1

2

Interactive
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Step 1   Choose a Flux Density Calibrator

3C286 LST range:
08:40−12:45 or 14:15−18:25

(30° < EL < 80°)

3C48 LST range:
20:45−00:50 or 02:30−06:30

(30° < EL < 80°)

IRC+10216
LST range: 05:40−13:50
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Step 1   Source Catalog is Complete
IRC+10216    ➞ Science Target
J0954+1743  ➞ Complex Gain Calibrator (plus reference pointing)
J1229+0203  ➞ Bandpass & Delay Calibrator
J1224+0330  ➞ Reference Pointing Calibrator for Bandpass/Delay
3C286           ➞ Flux Density Scale Calibrator (plus reference pointing)
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Step 2   Accessing the Resource Catalog Tool

In the OPT: click on Instrument Configurations

Interactive
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Step 2   Create a Resource Catalog
File → Create New → Catalog

Share the catalog 
with co-authors

provide a name

1

2 3

Interactive
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Step 2   Resource to be Created

Ka-band 8-bit instrument configuration
• Spectral Lines

• HC3N (νo= 36.39232 GHz)
• SiS (νo= 36.30963 GHz)
• V (radio, LSR) = -26 km/s 
• ΔV ~ 35 km/s



NRAO Community Days Event35

Step 2   Create a Resource in the Catalog
File → Create New → 8-bit Instrument Configuration

Default view of an 8-bit 
instrument configuration.

1

2

3

Interactive
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Step 2   Basics Tab

provide a name

select receiver band: Ka (26.5GHz - 40.0GHz)

adjust the correlator integration time according 
to array configuration  (3 sec for D-config)

Interactive
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Step 2   Create a Spectral Line Resource
1.  Lines Tab: Enter source position and line setup.

- HC3N (νo= 36.39232 GHz, V (radio, LSR) = -26 km/s, ΔV ~ 35 km/s)
- SiS (νo= 36.30963 GHz, V (radio, LSR) = -26 km/s, ΔV ~ 35 km/s)

2.  Basebands Tab: Adjust the baseband center frequencies as needed and 
turn on the Doppler Line setting. 

3.  Line Placement Tab: Generate the lines within the basebands.

4.  Subbands Tab: Check the location of the lines to see where they fall 
relative to the 128 MHz boundaries (should be > 6 MHz from them).

5.  Validation Tab: Check for errors and warnings.

Once we import the resource into an SB within the OPT, we will then be able 
to double check the center frequency calculations using the Dopset tool.
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Step 2   Lines Tab

Enter science target 
source coordinates.

Enter source position
09:47:57.382, 13:16:40.66

Interactive
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Enter spectral line information
HC3N (νo= 36.39232 GHz)
SiS (νo= 36.30963 GHz)
V (radio, LSR) = -26 km/s 
ΔV ~ 35 km/s

39

Step 2   Lines Tab

Add Line

Interactive
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Enter spectral line information
HC3N (νo= 36.39232 GHz)
SiS (νo= 36.30963 GHz)
V (radio, LSR) = -26 km/s 
ΔV ~ 35 km/s

40

Step 2   Lines Tab

Copy Last Line

Interactive
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Step 2   Lines Tab

Take note of these two calculated values:
36.396 GHz and 36.313 GHz
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Step 2   Ka-band Spectral Line Resource

The two 1 GHz wide basebands of the 8-bit samplers.

We need to adjust the baseband center 
frequencies so they overlap with the lines. 

A0/C0

B0/D0
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Step 2   Create a Spectral Line Resource
1.  Lines Tab: Enter source position and line setup.

- HC3N (νo= 36.39232 GHz, V (radio, LSR) = -26 km/s, ΔV ~ 35 km/s)
- SiS (νo= 36.30963 GHz, V (radio, LSR) = -26 km/s, ΔV ~ 35 km/s)

2.  Basebands Tab: Adjust the baseband center frequencies as needed and 
turn on the Doppler Line setting. 

3.  Line Placement Tab: Generate the lines within the basebands.

4.  Subbands Tab: Check the location of the lines to see where they fall 
relative to the 128 MHz boundaries (should be > 6 MHz from them).

5.  Validation Tab: Check for errors and warnings.

Once we import the resource into an SB within the OPT, we will then be able 
to double check the center frequency calculations using the Dopset tool.
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Step 2   Basebands Tab
Adjust baseband center frequencies and turn on the Doppler Line setting for HC3N in 
A0/C0 and SiS in B0/D0. (Ignore the error message at the bottom of the Basebands 
tab. It is generated because there are no subbands within the basebands.)

A0/C0 adjust to 36.32 GHz
B0/D0 adjust to 36.25 GHz

Interactive
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Step 2   Create a Spectral Line Resource
1.  Lines Tab: Enter source position and line setup.

- HC3N (νo= 36.39232 GHz, V (radio, LSR) = -26 km/s, ΔV ~ 35 km/s)
- SiS (νo= 36.30963 GHz, V (radio, LSR) = -26 km/s, ΔV ~ 35 km/s)

2.  Basebands Tab: Adjust the baseband center frequencies as needed and 
turn on the Doppler Line setting. 

3.  Line Placement Tab: Generate the lines within the basebands.

4.  Subbands Tab: Check the location of the lines to see where they fall 
relative to the 128 MHz boundaries (should be > 6 MHz from them).

5.  Validation Tab: Check for errors and warnings.

Once we import the resource into an SB within the OPT, we will then be able 
to double check the center frequency calculations using the Dopset tool.
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Step 2   Line Placement Tab
Generate the HC3N line within the A0/C0 baseband.

2
1

3

Interactive
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Step 2   Line Placement Tab

Generate the SiS line within the B0/D0 baseband.

2

1
3

Interactive
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Step 2   Create a Spectral Line Resource
1.  Lines Tab: Enter source position and line setup.

- HC3N (νo= 36.39232 GHz, V (radio, LSR) = -26 km/s, ΔV ~ 35 km/s)
- SiS (νo= 36.30963 GHz, V (radio, LSR) = -26 km/s, ΔV ~ 35 km/s)

2.  Basebands Tab: Adjust the baseband center frequencies as needed and 
turn on the Doppler Line setting. 

3.  Line Placement Tab: Generate the lines within the basebands.

4.  Subbands Tab: Check the location of the lines to see where they fall 
relative to the 128 MHz boundaries (should be > 6 MHz from them).

5.  Validation Tab: Check for errors and warnings.

Once we import the resource into an SB within the OPT, we will then be able 
to double check the center frequency calculations using the Dopset tool.
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Step 2   Subbands Tab

HC3N

Check line placement within the subband (spectral window).

Avoid using Snap To Grid and Fix To Baseband 
when preparing spectral line observations.

Interactive
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Step 2   Subbands Tab

SiS

Check line placement within the subband (spectral window).

Avoid using Snap To Grid and Fix To Baseband 
when preparing spectral line observations.

Interactive
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Step 2   Create a Spectral Line Resource
1.  Lines Tab: Enter source position and line setup.

- HC3N (νo= 36.39232 GHz, V (radio, LSR) = -26 km/s, ΔV ~ 35 km/s)
- SiS (νo= 36.30963 GHz, V (radio, LSR) = -26 km/s, ΔV ~ 35 km/s)

2.  Basebands Tab: Adjust the baseband center frequencies as needed and 
turn on the Doppler Line setting. 

3.  Line Placement Tab: Generate the lines within the basebands.

4.  Subbands Tab: Check the location of the lines to see where they fall 
relative to the 128 MHz boundaries (should be > 6 MHz from them).

5.  Validation Tab: Check for errors and warnings.

Once we import the resource into an SB within the OPT, we will then be able 
to double check the center frequency calculations using the Dopset tool.
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Step 2   Validation Tab
Check for errors and warnings.

Interactive
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Step 2   Validation Tab
Correlator Resource Table



NRAO Community Days Event54

Step 3   Observation Preparation Tool (OPT)

In the OPT: click on Observation Preparation

Due to shortness of time, we will skip a few steps in 
the OPT portion of the tutorial and provide an xml file 
of the completed SB.

Interactive
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3

55

Step 3   Observation Preparation Tool (OPT)
File ➞ Create New ➞ Test Project

2

1

Interactive
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Step 3   Project
Interactive
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Step 3   Program Block

Drag over 
configuration

Interactive
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Step 3   Program Block

List of Scheduling Blocks created by the observer.

Once an SB has been observed, the Execution Block will be listed.
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Step 3   Scheduling Block Information

• SB name: IRC+10216 Ka
• LST start range:

– LST target/complex gain_cal/ref_cal: 05:40-13:50  
– LST Bandpass_cal: 08:55-16:00
– LST Flux_cal: 08:40-18:30 (avoid 12:45-14:15, EL > 80°)

Assuming a 3 hour long SB: 
One possible LST start range is 08:30−09:45 

(if the flux cal (3C286 rising) is observed at the end)

• Wind and APL constraints: choose Ka-band
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Step 3   Scheduling Block Information Tab

Provide a name

LST start range
08:30−09:45

Interactive

Valid special characters are:
spaces  +  -  _  * /
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Step 3   Scheduling Block Information Tab

Ka-band 
Wind & APL 
constraints

Interactive
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Step 3   Scheduling Block － Scans
• Start-up Sequence

- Setup scan for each instrument configuration: 
‣ Ka-band configuration
‣ X-band reference pointing configuration

- X-band reference pointing scan on J0954+1743 
(For high frequency observing, the start-up should sum up to at least 12 min.)
• Ka-band Complex Gain calibrator J0954+1743 
• Ka-band Target-Complex Gain cal loop 

- Repeat the last three steps 
• X-band reference pointing on J1224+0330 for Bandpass/Delay cal
• Ka-band scan on Bandpass/Delay cal J1229+0203 
• X-band reference pointing on Flux cal 3C286
• Ka-band scan on Flux cal 3C286



NRAO Community Days Event63

Step 3   Scheduling Block － Scan Intents
Select the appropriate scan intent for each source.

IRC+10216    ➞ Observe Target

J0954+1743  ➞ Calibrate Complex Gain (A and P)

J1229+0203  ➞ Calibrate Bandpass & Calibrate Delay

J1224+0330  ➞ Calibrate Offset Pointing (only used for reference pointing)

3C286           ➞ Calibrate Flux Density Scale

setup scans  ➞  Setup Intent 

When using reference pointing, check the 
Apply Last box to all standard observing mode 
scans that follow.  Otherwise, the reference 
pointing corrections will not be applied.
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Step 3   Create a New Scan
File → Create New → Scan → In

1

2

3
4

Interactive
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Step 3   New Scan
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Step 3   Import Source

1

2
3

5

Import the complex gain calibrator, J0954+1743, from the VLA calibrator catalog.

4

Interactive
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Step 3   Import Ka-band Resource

1 2

3
4

Import the Ka-band instrument configuration you 
created from your resource catalog.

Interactive
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Step 3   Ka-band Setup Scan Details

Scan name can be changed (spaces +  -  _  /  are valid special characters)

Do not check Apply Last for initial setup 
scans or for reference pointing scans.

Setup scan must be at least 1 minute in Duration (LST) and 
select the Setup Intent (unselect Observe Target intent).

Interactive
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Step 3   Copy Scan
Edit ➞ Copy STD: <scan name>

1

2

Interactive
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Step 3   Paste Scan
Edit ➞ Paste ➞  Paste After STD: <scan name>

1

2
3

Interactive
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Step 3   Import X-band Pointing Resource 

1

2

3

4

Import the X-band pointing resource from the NRAO Defaults resource catalog.

Change the 
scan name.

Copy/paste this scan to create 
the reference pointing scan.

Interactive
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Step 3   X-band Reference Pointing Scan

Change scan mode to Interferometric Pointing

Increase scan duration to at least 10 minutes 
to allow for a 12 minute start-up.

Calibrate Offset Pointing 
intent will automatically be 
selected.

Change scan name

Interactive
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Step 3   Ka-band Complex Gain Cal Scan
(Copy/paste Ka-band setup scan to create this scan.)

Change name of scan.
(We used phase simply to shorten the name of the scan.)

Select Apply Last to apply reference pointing corrections.

Select appropriate scan intent for 
the complex gain calibrator.

2 minute scan duration is dependent on 
various factors (i.e., slew time, required on 
source time, etc.)

Interactive
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Step 3   Create a Loop

File → Create New → Scan Loop → After

Create a loop for the science target and complex gain cal scans.

1
2

3
4

Interactive
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Step 3   Edit Loop

Provide a name
Adjust the loop iterations to 7

Since we start with a complex gain calibrator before the 
loop, we will not use the bracket feature within the loop. 

Interactive
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• Select the loop:
‣ File → Create New → Scan → In

• Select the scan you want to copy:
‣ Edit → Copy STD: <scan name>
‣ Select the loop you want to paste the scan into:
‣ Edit → Paste Into (nX) <loop name>

(where n is the loop iterations)

The icons shown below can also be used to add a new scan, 
cut/copy/paste a scan, or move a scan up or down within the SB.  
(In the OPT, hover over each icon for a short description.)

76

Step 3   Options for Adding Scans to a Loop 
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So you may jump ahead to see the completed SB described in this 
tutorial, we have provided a file called:

OPT_demo.xml 

To download the file:
‣ Go to ftp://ftp.aoc.nrao.edu/pub/NRAO-CDE/INAOE2018 
‣ Right-click on OPT_demo.xml
‣ Save Link As
‣ Save to Desktop or Downloads folder

To import the file into the OPT:
‣ Go to File → Import Project
‣ Browse to locate the file and then import. (Click once and wait 

a few seconds for the import process to complete.)
‣ Then expand the contents to see the Project, Program Block, 

and Scheduling Block.

77

Step 3   Import xml File

ftp://ftp.aoc.nrao.edu/pub/NRAO-CDE/INAOE2018
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Step 3 

High Freq Start-up Sequence:
setup scans + reference pointing

ComplexGain - Target - ComplexGain
+ reference pointing

(bracketing is important for best 
phase calibration)

Bandpass/Delay & Flux Density
+ reference pointing

Finished 
Scheduling 
Block

Select ‘+’ to open all loops in SB.
Interactive
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Step 3   Reports Tab

Check LST start range (08:30−09:45) for appropriate on source time 
and EL for all scans:
• Required minimum on source time, after slewing: 

– Reference pointing scans:
‣ 2.5 min on source

– Standard observing scans:
‣ 40 sec on source for flux density calibration
‣ 20 sec on source for all other calibration and science target scans 

– More time may be required depending on the required signal to noise.
• High frequency elevation limits:  30° < EL < 80°
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Step 3   Reports Tab
Interactive
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Step 3   Reports Tab:  Schedule Summary/Report
When stepping through the LST start range, check the schedule Summary 
Report for on source time, elevation limits, warnings or errors if there are any 
(i.e., antenna shadowing), etc..  Note, no time on source for the setup scans is ok.

Open all 
loops

Interactive
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Step 3   Reports Tab:  Time On Source Summary
The Time On Source Summary provides a sum of the total time spent 
on source for each source by scan intent and resource.  This number 
will change for all LST start times due to changes in slewing.
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Step 3  

Double check the resources used are correct and each have a 
corresponding setup scan.  If an unintended resource is selected in a 
scan, it will appear in the Instrument Configuration Summary.

For more details, click on 
Show All Subbands.

Reports Tab:  Instrument Configuration Summary
Interactive
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Step 3   Double Check Lines Using Dopset

OPT Center Frequency Calculations 
HC3N = 36.39735821 GHz
SiS = 36.31465677 GHz

OPT Input Parameters
64846 LST day, 08:30 LST, IRC+10216 position, 
and respective line rest frequencies
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Step 3   Compare Dopset & OPT Calculations

HC3N Center Frequency Calculations 
OPT     = 36.39735821 GHz
Dopset = 36.397358744 GHz

SiS Center Frequency Calculations
OPT     = 36.31465677 GHz
Dopset = 36.314657295 GHz

Dopset Input Parameters
64846 LST day, 08:30 LST, 
IRC+10216 position, and 
respective line rest frequencies

http://www.vla.nrao.edu/astro/guides/dopset/ 

http://www.vla.nrao.edu/astro/guides/dopset/
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Step 3   Validation and Submission Tab
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Online Documentation

OPT Manual
go.nrao.edu/opt-doc

Guide to Observing with the VLA
go.nrao.edu/vla-obs 

http://go.nrao.edu/opt-doc
http://go.nrao.edu/vla-obs
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NRAO HelpDesk

• All submitted SBs are checked/validated by the VLA DAs.  
• Unless asked:

– We do not check the validity of the calibrators.
– We do not check the scientific accuracy of the 

correlator resource(s).
• Observers will be contacted if there are any problems 

with an SB.

Please submit questions to the 
NRAO HelpDesk

help.nrao.edu 

https://help.nrao.edu

