Facilities > VLA > Documentation > Manuals > OPT > OPT Tutorial Example

OPT Tutorial Example

by Gustaaf Van Moorsel last modified Dec 29, 2017 by Lorant Sjouwerman

An Observation Preparation Tool (OPT) tutorial.

This document describes how to create VLA observing scripts using the Observation Preparation Tool (OPT) and its associated suite of tools: the Source Catalog Tool (SCT) and the Resource Catalog Tool (RCT). We will use an example source (science target) and resource (instrument configuration) to show how to design an observing script, more commonly called a Scheduling Block (SB), using the OPT. After following this tutorial, you should be able to create an SB appropriate for your science goals.

Note that this tutorial does not replace or substitute for the more complete content that can be found in the official, full content OPT Manual, in the Guide to Observing with the VLA, or in the VLA Observational Status Summary (etc.).

 

The Science Case

We want to observe a planetary nebula, NGC 2371, for thermal and maser lines and possible associated stellar continuum. In the proposal we argued we need D-configuration to potentially detect extended ammonia hyperfine emission, NH3(1,1), NH3(2,2), and the potentially point-like water and hydroxyl masers. The rest frequencies and spectral resolution we are trying to capture are listed in the table below, as well as the anticipated time on source to achieve our RMS noise and brightness temperature. The time allocation is 2.5 hours and all velocities are assumed in the LSR Radio frame.

Science Target from Proposal
NGC 2371 Notes
Coordinates (J2000) 07h 25m 34.68s, +29d 29' 26.4" planetary nebula
Velocity 21 km/s LSR/Radio frame
LST start range 02:16 to 18:51 lower elevation limit of 25 degrees

 

Instrument Configurations (resources)

Line Frequency (MHz) Coverage (km/s) Resolution (km/s) Notes
L-band about 15 min on-source in L-band
OH 1612 1612.2310 100 0.2
OH 1665 1665.4018 100 0.2
OH 1667 1667.3590 100 0.2
OH 1720 1720.5300 100 0.2
K-band about 1h45m on source in K-band
H2O 22235.1 100 0.1
NH3(1,1) 23694.5 (23692.9-23696.1) 100 2.3 hyperfine lines span 3.2 MHz
NH3(2,2) 23722.6 (23720.5-23724.7) 100 2.3 hyperfine lines span 4.2 MHz
continuum K-band

Other line frequencies for the VLA can be found in the line list in the OPT manual.

 

The Approach

To observe this experiment, the SB must contain the details of the science target source(s), calibrator(s), and resource(s). For calibrators and continuum resources, the SCT and RCT provide standard catalogs with calibrator positions and default instrument configurations, respectively. In general, the science target and spectral line setup should be provided by the observer before the SB can be created. The basic steps are as follows:

  1. Supply the science target source coordinates to the SCT and determine appropriate calibrators;
  2. Create the spectral line resource in the RCT or any other personalized (continuum) resource;
  3. Create an SB in the OPT by combining sources and resources into an ordered scan list.

Steps 1 and 2 can be done in reverse order. For continuum observations, step 2 can be skipped if an NRAO default resource is used, and step 1 can be skipped if the science target source(s) has already been imported and the calibrators have been determined. In this tutorial, however, each step will be shown to explain the components of the SCT, RCT, and OPT. During this process, remember to create unique names for catalogs, sources and resources.

 

Define Source Coordinates in the SCT

If the proposal was submitted to NRAO using the Proposal Submission Tool (PST), the coordinates entered in the PST will transfer to the SCT about a month before the first eligible array configuration (an email notification will be sent to the PI and co-I's). If the proposal was allocated time through another Time Allocation Committee (TAC) (e.g., a NASA panel), this transfer of source(s) to the SCT will not occur. In any case, log into the OPT with your my.nrao.edu login and navigate to the SCT by selecting the Obs Prep tab, then click on Login to the Observation Preparation Tool, and then click on Sources located in the dark blue navigation bar at the top (see Figure 1).

Figure 1: The OPT navigation bar.

There are three ways to define sources in the SCT:

  1. Direct transfer from the PST, done by NRAO staff;
  2. Upload of a text file (e.g., the same that was uploaded/exported from the PST), or;
  3. Manual creation of each source in the SCT.

If there is a source catalog labeled with a proposal code in the left-hand side below the VLA source catalog, it is likely that the source positions were transferred from the PST to the SCT. Click on the source catalog name to view the list of sources in the catalog and check that the positions entered in the PST conform to the accuracy needed. This is important, particularly if the PST only contains regions (e.g., for mozaics) or approximate coordinates.

If there is no catalog for the project, if the catalog is empty, or if the source coordinates are not accurate enough, then the source coordinates need to be entered or updated by the user.

If you have the source list that was uploaded to the PST for your proposal at hand, you can upload this list (with or without updates, using the same PST format) by selecting from the menu File → Import. You can add a line with the anticipated catalog name if it is the first line of the file and that line starts with an asterisk (or modify the New Catalog later in the properties tab). Example PST format files are given in the source list explanation in the OPT manual text-file section.

If needed, and for the purpose of learning the components of the SCT, create a new catalog by selecting from the menu File → Create New → Catalog (see Figure 2).

Figure 2: Create a new source catalog.

Give the new catalog an appropriate name in the Properties tab, e.g., "18A: NGC2371"; then select the Sources tab (see Figure 3).

Figure 3: Selecting the Sources tab under the new source catalog.

Next, create a new source by selecting from the menu File → Create New → Source (see Figure 4).

Figure 4: Creating a new source.

Provide a name and the coordinates that represent the field center (see Figure 5). When done, return to the catalog by selecting its name (on the left) or select "Return to <catalog name>" (located above the tabs). Repeat these steps for other sources.

f05-sct-sourcename
Figure 5: Enter source information.

When looking at the catalog listing, click on the blue icon on the left of a row to enter the source properties to make additional edits such as updating the PST-transferred position, or click on the right-most black icon (see Figure 6) to see which calibrators are nearby in the bulls-eye tool (opens a new browser tab) and remember any suitable ones for your target positions (see Figure 7).

f06-sct-sourcelist
Figure 6: Sources in catalog information.

 

f07-sct-sourcebullseye
Figure 7: Bulls-eye view of source and its surrounding calibrators.

While it is useful to copy your calibrators to the catalog, this is not required as they are already defined in the VLA calibrator list. As an example of how this is done, use the Advanced search in the upper left-hand side of the SCT (see Figure 8).

f08-sct-search
Figure 8: Advanced Search.
  1. Select the VLA catalog and any other catalog you want to search.
  2. Click the Cone Search box to activate the parameters field.
  3. Type in the coordinates of your target (which do not have to be very accurate, e.g., 7h 25m and 29d 30'), and a radius of the cone to search.
  4. Click on the Search button.

The sources that match the selection criteria, here within 10 degrees of the position, are listed at the bottom and sorted by increasing distance from the entered position. Hover over the Details field of each source to judge the flux and structure for use as a phase calibrator for your project (see Figure 9).

f09-sct-searchresult
Figure 9: The source details pop up when hovering over the "Details" field of the source in the table.

If none of the sources match your requirements, use a larger search radius. Otherwise either list the source name for future use, or click the checkbox in front of the calibrator you want to use and select from the menu Edit → Copy → Sources (see Figure 10) to copy the source. Then paste it into your project catalog (click the project catalog and then select from the menu Edit → Paste → Sources) (see Figure 11). You can do this as many times as you want. You may want to also include your flux density and bandpass/delay calibrators, and if applicable also any polarization and reference pointing calibrators.

Figure 10: Using Edit → Copy → Sources from the general calibrator list after a search.

 

Figure 11: Using Edit → Paste → Sources to the project's source catalog.

If you have selected coordinates near the science target (NGC 2371), you will find that source J0741+3112 is bright (>1 Jy/beam at any frequency) and has useful calibrator properties (code P and S) for the low and high frequency ranges in compact array configurations. Because of its simple structure, we can use this calibrator as a phase (complex gain) calibrator for both the L- and K-band observations. Because the calibrator is bright and approximately flat spectrum, we may also use it as a delay and bandpass calibrator, especially if it is brighter than our flux density calibrator. For high-frequency observations we need a pointing calibrator, bright and point-like in X-band, and this calibrator can be used for that as well.

For a flux density calibrator, simply go to the Flux Cal group in the VLA list (located on the left) (see Figures 12 and 13). Note, 1411+522=3C295 should only be used at low frequencies (P- and L-band) in the compact array configurations (C- and D-configuration). Here we can use 0137+331=3C48 at the beginning of the SB or 1331+305=3C286 at the end.

Figure 12: Using Edit → Copy → Sources from the flux density calibrator list.

 

Figure 13: Using Edit → Paste → Sources to the project's source catalog.

To find an alternative bandpass calibrator, in case the complex gain calibrator is not as bright, increase the search radius to 40 or 50 degrees and use the Search by Flux Density parameter set to ≥ 0.6 (this source needs to be bright), and select the band you are using. Similar for reference pointing calibrators, use a moderately small radius (15 degrees) and require a P/S calibrator that is ≥ 0.6 in X-band. More hints and suggestions are in the Guide to Observing with the VLA. Check your sources for correctness, then move on to the RCT for the instrument configuration (i.e., click on "Instrument Configurations" in the blue menu bar at the top).

Define the Resources Using the RCT

If the required resource is only continuum, it should be possible to choose from the standard setups as defined in the NRAO Defaults catalog or create your own. However, if the science requires more than 64 channels and/or channels narrower than 2 MHz, e.g., spectral line observations, you will have to create your own resource. In any case, log into the OPT (my.nrao.edu) and navigate to the RCT by clicking on Instrument Configurations in the dark blue navigation bar at the top.

Before creating a resource or a collection of resources, we will first need to create a resource catalog. This needs to be done regardless if you have a project in the OPT or not, since we do not currently have a way to import the resource setup from the PST into the RCT. From the top menu, select from the menu File → Create New → Catalog (see Figure 14). Give the resource catalog an appropriate name, e.g., the project code or "18A: L and K lines".

Figure 14: Creating a new resource catalog.

There are two ways to define resources in the RCT:

  1. Copy/paste an existing resource to then modify, or;
  2. Manually create the resource.

In this tutorial, the experiment includes spectral lines; the best, and more accurate, method is to start from scratch. Since we are observing in two bands (K and L), two different setups will be created. The L-band resource will use the 8-bit samplers while the K-band will use the widest possible bands to measure the stellar continuum and will require the 3-bit samplers.

 

L-band with Lines and Continuum

Create a science resource by selecting from the menu File → Create New → 8-bit Instrument Configuration (see Figure 15), give it a descriptive name (hit the Tab key to set the name), select L-band from the drop-down menu, and enter the default integration time that corresponds to the band and array configuration (5 seconds for D-configuration) (see Figure 16). For more information regarding the integration time, consult the OSS.

Figure 15: Creating an 8-bit Instrument Configuration.

 

f16-rct-catalog8bitbasic
Figure 16: Editing the Basics of the L-band resource.

Select the Lines tab and import or enter in your source position (used for Doppler calculations later) (see Figure 17). Note that for each different target position or velocity, i.e., a new Doppler setting, you would need to create a separate resource regardless if the rest of the setup is the same. For each line to be observed with its own frequency settings, click the Add Line button to enter the particulars (see Figures 17 and 18 for all lines), or prepare a file with the details to use the Import Spectral Lines button.

f17-rct-catalog8bit
Figure 17: The Lines tab input.

 

f18-rct-catalog8bit

Figure 18: All the L-band line input.

In general, the setup requires about 1.1kHz channels spread over 550kHz (calculated in the Minimum Range and Channel Separation columns). Figure 19 shows that the lines labeled L1-L4 are somewhere in the A0/C0 (green pair of lines at the top) and B0/D0 (red pair of lines at the bottom) basebands and are away from the baseband edges; this means they can be generated in the baseband that the lines intersect, either the green (top) or the red (bottom) baseband. Since the lines intersect both basebands, we'll use A0/C0 (green / top).

f19-rct-catalog8bit

Figure 19: Graphical view of spectral line placement.

Select the Line Placement tab (skipping the Basebands tab for now) and click the Generate button for each of the lines (see Figure 20). These actions will generate the spectral windows as specified (center and width) in the Lines tab and may be changed in the Subbands tab.

f20-rct-catalog8bit
Figure 20: Generating lines within the A0/C0 baseband.

Select the Subbands tab to see where the lines appear within the A0/C0 subbands (see Figure 21). Note the thin green lines in A0/C0 fall well between the dotted lines representing the 128MHz subband boundaries. The goal is to have a large separation between the lines and subband boundaries so that the lines are not observed in the boundaries where sensitivity degrades to zero.

f21-rct-catalog8bit
Figure 21: The Subbands tab. The solid lines within the white box are the spectral lines.

As the line subbands are very narrow (1MHz) and only cover 4MHz total in the baseband, it is recommended to add some wider (128MHz) subbands or widen the existing subbands. The latter may not be possible if the total allocated baseline board pairs (BlBPs) in the table at the top reaches 64 (see Figure 22). Wider subbands are useful to better determine the baseband delay. The simplest method is to click the Fill Subbands button; this adds another 4 BlBPs. Then distribute them near the center of the baseband (i.e., move the first one or two subbands to the middle by using the pull down menus in the Central Frequency column, see Figure 23a and 23b), taking into account the anticipated RFI in these frequency ranges.

f22-rct-catalog8bit
Figure 22: The number of BlBPs used and other information in the table at the top.

 

f23a-rct-catalog8bit
Figure 23a: Add four additional 128 MHz subbands using the Fill Subbands button, which adds them by default from left to right. Re-centering the added, individual 128 MHz subbands is done by using the pull-down menu in the Central Frequency column; here the leftmost subband is moved to the end of the rightmost. The solid lines within the white box are the spectral lines.

 

f23b-rct-catalog8bit
Figure 23b: After moving the leftmost subband to the end of the rightmost, the coverage of the added continuum subbands is located in the second to fifth intervals of the 128 MHz baseband. The originally placed line subbands are still visible as lighter colored regions in the baseband and are not moved. The solid lines within the white box are the spectral lines.

Now select the Basebands tab, click the A0/C0 Doppler line checkbox and select the Doppler line to use in the calculation, typically the one in the middle of the baseband is used, in this example, OH 1665. This should display the Doppler settings for the baseband (position, velocity, etc.) in the columns to the right. Note that B0/D0 is not used as there are no defined subbands. (see Figure 24.)

Figure 24: The Basebands tab Doppler Line information.

The Validation tab summarizes the resource. When done, return to the catalog by clicking its name or by selecting "<catalog name>" in blue font above the resource and repeat these steps for other spectral line resources, such as the K-band resource explained in the next section.

 

K-band with Lines and Continuum

Under your resource catalog, create a science resource by selecting from the menu File → Create New → 3-bit Instrument Configuration. This will generate a New Resource Wizard pop-up box. In the New Resource Wizard (see Figure 25) select the Observing Band (K (18.0GHz - 26.5HGz)), the Array Configuration (D), and Polarization Mode (Full). Since D-configuration was selected, the default integration time of 3 seconds will automatically be set for the high frequency observing (this can be adjusted in the Basics tab if needed). Click the Generate button and you should see a page familiar to the L-band setup but with 4-colored basebands at the top (see Figure 26).

Figure 25: The New Resource Wizard for 3-bit instrument configurations.

 

f26-rct-catalog3bit
Figure 26: The K-band Basics tab. The four basebands are, from top to bottom: A1/C1 (blue), A2/C2 (purple), B1/D1 (yellow), and B2/D2 (red).

Proceed with the same steps as with the L-band resource setup:

  1. Under the Basics tab, give the K-band resource a descriptive name (see Figure 26),
  2. Select the Lines tab to enter in the source position and use the Add Line button to add three lines: H2O, NH3(1,1), and NH3(2,2). See Figure 27 for the parameters.
f27-rct-catalog3bit
Figure 27: The spectral line parameters and source position in the K-band resource Lines tab.

Note the H2O maser line asks for about 7.4 MHz coverage with 7.4 kHz channels, requiring 2 BlBPs, and the NH3 lines ask for about 8 MHz coverage with 180 kHz channels, with one BlBP each. However, as the NH3 hyperfine lines are spread over up to 4.2 MHz (see the table in the science case at the top of this tutorial), the total coverage for these lines need to be expanded by about the same amount by specifying 160 km/s coverage instead of 100 km/s so that the total coverage expands from 7.4 MHz to at least 11.6 MHz.

Figure 27 shows the L1 line (H2O maser line) will be very close to the A2/C2 (purple) and B1/D1 (yellow) baseband edges. The L2 and L3 lines are fine in the A2/C2 (purple) baseband. Due to sensitivity loss at the roll-off of the baseband, we recommend avoiding line placement at the baseband edges. This means that the baseband centers need to be adjusted in the Basebands tab.

Deciding which baseband to use for the H2O maser and how much to move the basebands around is a preference issue with some science constraints. The method below is just an example.

Adjust the center frequency of the B1/D1 (yellow) baseband. To get the line in a subband that is not an edge subband, the easiest method is to move the center up in frequency by a multiple of 128 MHz: to start, we will use 256 MHz (see Figure 28). As the B/D (or A/C) 1 and 2 baseband centers cannot be separated more than about 2.5 GHz, you would also move up the fourth baseband, B2/D2 (red), by a similar amount in case the B1/D1 (yellow) baseband needs to move up even more, which also avoids a potential gap in the continuum coverage. The L1 (H2O) line now is well within the B1/D1 (yellow) baseband, so we can now continue with the Line Placement tab.

f28-rct-catalog3bit
Figure 28: The Basebands tab, adjusting the B1/D1 (yellow, 3rd from the top) baseband center frequency.

Under the Line Placement tab, the Generate buttons are disabled (see Figure 29), meaning too many resources have been allocated. You can see in the small box near the top right we are currently using all 64 BlBPs (top of Figure 29).

f29-rct-catalog3bit
Figure 29: The Line Placement tab showing disabled Generate buttons because (in the top table) all 64 of 64 available BlBPs are in use.

When the resource was initially created, the New Resource Wizard generates and fills all of the continuum subbands. To add lines, we have to delete some continuum subbands. Earlier we noted that the H2O line requires 2 BlBPs, so two continuum subbands should be deleted from the B1/D1 (yellow) baseband (since that is where the H2O line will be placed). The NH3 lines each require one BlBP, so two continuum subbands should also be cleared from the A2/C2 (purple) baseband. The ideal subbands to remove are typically the edge subbands as these have less sensitivity. Make sure there are no crucial frequencies in the subbands that are deleted.

In the Subbands tab, select the B1/D1 baseband tab. Delete the first and last subbands (the ones with highest and lowest center frequencies) by clicking on the red icon at the far right of the table. The yellow subbands at either end in the baseband graphic should have been cleared (see Figure 30). Do the same for the A2/D2 (purple) baseband (see Figure 31) and note that now only 60 of the 64 BlBPs (see figure 32) are in use and thus 4 BlBPs are now available for the lines we want to observe.

f30-rct-catalog3bit
Figure 30: The Subbands tab showing the removal of two subbands within B1/D1 (yellow, leftmost and rightmost are removed).

 

f31-rct-catalog3bit
Figure 31: The Subbands tab showing the removal of two subbands within A2/D2 (purple).

 

f32-rct-catalog3bit
Figure 32: The summary box indicating that now only 60 of 64 BlBPs are in use.

Now go back to the Line Placement tab and press Generate for the H2O maser line frequency setup. The default is to place this in the first available baseband, A2/C2 (purple). However, we decided to put this line in the B1/D1 (yellow) baseband so we need to select that from the baseband drop-down menu. Note, this issues a warning (see Figure 33a).

f33a-rct-catalog3bit

f33b-rct-catalog3bit

Figure 33a: Subband warnings when generating the H2O line. Figure 33b: Subband warnings when generating the NH3(2,2) line.

This is an important warning and will be addressed later, for now we will accept the warning and generate the line. The first NH3 line does not give a warning when generating, but the second one does (Figure 33b). Again, accept for now.

In the Subbands tab select the B1/D1 baseband to see the location of the L1 (H2O) line subband, indicated by the lighter yellow bar among the darker yellow continuum subbands. You will notice the H2O line is very close to a 128 MHz boundary at the right-hand side of the graph (see the right hand side of Figure 34a).

f34a-rct-catalog3bit
Figure 34a: The B1/D1 (yellow) baseband graphic containing L1 (H2O) line on the right hand side.

To better place this subband between the boundaries, the center frequency of the baseband should be shifted. We will try about 60 MHz toward lower frequencies. As there was still some room between the subband and the boundary, there is no absolute need to delete the line subband. However, for this tutorial, we will delete the line subband, adjust the B1/D1 baseband center frequency, then regenerate the H2O line. This will allow us to see any new warnings if there are multiple line subbands in the baseband. Similarly, we will do the same for the case of the NH3 lines below. We now delete the line subband located at the bottom of the table; the little yellow triangle next to the center frequency is the warning indicator (Figure 34b). Note, if you hover your mouse over this icon, you can then read the warning message.

f34b-rct-catalog3bit
Figure 34b: The newly created line subband with the warning indicator triangle. We should delete this subband and regenerate it.

To view the placement of the NH3 lines, select the A2/C2 (purple) baseband. These lines will appear as lighter purple bars on both sides of a 128 MHz boundary (see Figure 35).

f35-rct-catalog3bit
Figure 35: The A2/C2 (purple) baseband containing the two NH3 lines which are close to a 128 MHz boundary.

Again, to move away from the boundary, the best change is about 60 MHz either lower or higher in frequency. As the shift for B1/D1 is lower, we can be consistent and choose lower shift for A2/C2 to limit the overlap with A1/C1 and reduce the gap with B1/D1. Since the second NH3 subband overlapped the boundary, we will delete the subband, and it is good practice to do this for the other line(s) generated. In this case, delete the bottom two subbands.

Now we will go back to the Basebands tab to adjust the center frequencies for A2/C2 and B1/D1 by 60 MHz and B2/D2 as well (see Figure 36).

f36-rct-catalog3bit
Figure 36: Adjusting center frequencies in the Basebands tab.

Then regenerate the lines as before in the Line Placement tab and make sure there are no warnings.

In the Subbands tab, for A2/C2 and B1/D1, we now see the line subbands are nicely placed between the 128 MHz boundaries.

We finally activate the Doppler setting by going to the Basebands tab and selecting the A2/C2 and B1/D1 checkboxes. Using the H2O line in the middle of the frequency band is probably the best choice for performing the calculations; but one may choose different lines for different basebands if desired. (See Figure 37).

f37-rct-catalog3bit
Figure 37: The Basebands tab, activating Doppler setting for A2/C2 and B1/D1 (and the others as well to retain the relative shifts).

Since the New Resource Wizard automatically filled the subbands, the continuum will also be measured in the subbands that are not the line subbands.

Note the Total Data Rate in the table seen in Figure 37 is still within the General Observing limit of 25 MB/s. Otherwise the setup would require adjustment to use less subbands, less basebands, less channels, fewer polarizations, or by increasing the correlator integration time. It is also helpful, for future resource setups, to double check the name you have given the resource is unique.

We are now ready to make a Scheduling Block (SB) in the OPT using the information we have entered in the SCT and the RCT. Click on the Observation Preparation link at the top to access the OPT.

 

Create a Scheduling Block in the OPT

About a month before the array configuration begins, proposers will receive an email that their project(s) have been made available in the OPT and are now ready for Scheduling Block (SB) creation. The Program Block (PB) will contain the allocated time for a particular configuration and scheduling priority. This tutorial example was allocated 2.5 hours. For learning purposes, it may be that you need to create your own Test Project within the OPT. You may do so by selecting from the menu File → Create New → Test Project and give the Test Project any name descriptive to you.

The PB should contain an empty SB in which the observer can create the observing scans (see Figure 38). You can rename the SB by selecting it and entering a descriptive name such as "NGC2371 OH H2O NH3". Note that some characters are not allowed in the naming, such as a comma or colon. The PB can also be renamed.

f38-opt-pbempty
Figure 38: The Project (P, orange) tree in the OPT, with a Program Block (PB, blue) and a Scheduling Block (SB, green)

The SB contains science scans, particularly loops (fast switching between the complex gain calibrator and science target source(s)) and other calibration (flux density, reference pointing, polarization, etc.) scans. The order in which they are created is not too important as long as they adhere to the requirements for observing. This example starts with the science scans before the overhead of the setup scans for the resource(s).

Things to Consider:

  • When observing multiple frequencies, start with high frequency resource(s), in case weather and/or atmospheric phase conditions deteriorate during the observation;
  • High frequency observing requires reference pointing scans;
  • Perform flux density and bandpass calibration (polarization is not in this tutorial example);
  • Complex gain calibrator and science target cycle time (fast switching) loops — 20 minutes for L-band and 7 minutes for K-band for D-configuration;
  • Anticipated L-band on-source time is 15 minutes (1 loop), K-band 1 hour 45 minutes (15 loops) for this project observation;
  • Switching between 8-bit and 3-bit requires 30 second requantizer gain setup scans;
  • Begin with the flux density calibrator (3C48 for this observation) at the start of the SB.

Note that there are different ways to create the SB. All SBs (must) include a start-up phase, a basic science observing component and other required overhead. It is a matter of preference how to get started; different guides may give different suggestions, i.e., building from the beginning of the observations with the initial overhead sequence or start setting up the target-calibration loops with the science in mind. Here the latter is chosen: to start with the science-focused scans and add/insert the overhead later on before the final fine-tuning (which always comes last).


Basic SB Outline

To create our science scans, we start with the simpler L-band observations. We want 15 minutes on source and can use a much longer cycle/loop time between the calibrator scans. However, we should also make sure the individual scans do not get too long (less than or equal to 10 minutes in total duration). We will set up one basic L-band loop: calibrator scan - target scans (two 7.5 minute scans totaling 15 minutes) - calibrator scan. Note that these can also be done without a loop. However, by placing them in a loop it is easier to copy/paste the combination of scans as a whole instead of moving each scan around separately later in the process.

Creating looped scans is done by selecting the SB and then selecting from the menu File → Create New → Scan Loop → In, followed by selecting from the menu File → Create New → Scan → In, to create the first scan within the loop (see Figures 39 and 40). This last step may also be done by clicking on the Page icon (second icon at the top of the left-hand column).

Figure 39: Creating a loop.

 

Figure 40: Creating a scan within the loop.

Within the [New Scan] entry fields, click the Import button in the Target Source field; this will bring up the VLA catalog by default. Select the calibrator you want to use (for this tutorial, J0741+331). Rather than scrolling through the entire list of calibrators, you may select the RA position to narrow the search (in this case RA 07, see Figure 41).

f41-opt-Lcalibrator
Figure 41: Importing a calibrator source.

To import the resource, click the Import button in the Hardware Setup field, select the project's resource catalog, and there you will see the L-band spectral setup you created (see Figure 42).

f42-opt-Lcal2
Figure 42: Importing a resource from project catalog.

To finalize this calibration loop scan, select the "Calibrate Complex Gain (A and P)" intent and set the scan length to a reasonable LST duration (e.g., 1 minute).

The next scan, for the science target, can be created by clicking the Page-+ icon (the third icon at the top), which copies the scan into a new scan with the hardware setup and source from the previous scan. Change the source to the science target by selecting your source catalog in the dialog box and adjust the Scan Timing to 00:07:30 Duration (LST) (see Figure 43). Note the Observe Target intent is the default scan intent. If you make a mistake, a scan or an entire SB can be deleted or cut by selecting it and clicking on the Scissors icon (the fourth icon at the top).

f43-opt-Lscan
Figure 43: A science target scan.

To duplicate the science target scan, click on the Copy icon (the fifth icon at the top), and paste it with the Paste icon (sixth item at the top) to increase the duration of the science target to twice 7.5 minutes. Finally, select the calibrator scan and copy/paste it to the last scan in the loop, this time by selecting from the menu Edit → Copy STD: J0741+3312, then click the last scan and select from the menu Edit → Paste After STD: NGC2371 (see Figures 44 and 45).

Figure 44: Copy scan STD: J0741+3312.

 

Figure 45: Paste After scan STD: NGC2371.

Now we will create a similar loop in K-band, and place it so it is observed before the L-band scans.

Select the L-band loop (rename it to "L-band loop" or something descriptive) and select from the menu File → Create New → Scan Loop → Before, and give the new loop a name, e.g., K-band loop. Since we want the K-band loop to run 15 times, set the Loop Iterations to 15 (see Figure 46).

f46-opt-Kloop
Figure 46: The K-band loop settings.

In the K-band loop we want to create a science target scan of 7 minutes and a complex gain calibration scan of 1 minute (see Figure 47). Since K-band observations require reference pointing calibrations, place another complex gain calibrator scan before the K-band loop (see Figure 47). Be sure to import the K-band setup for the Hardware Setup and use the "Calibrate Complex Gain (A and P)" scan intent for the complex gain calibrator scans.

f47-opt-Kloop2

Figure 47: Filling the K-band loop and adding the complex gain calibrator before the loop.

Because K-band is high frequency, we will be adding reference pointing scans (see Figure 48). We will select the Apply Last Reference Pointing setting for all K-band scans, except for the pointing scan itself. Note we can extend the complex gain calibrator scan before the loop and use it as a bandpass calibrator if we decide to do so. However, 3C48 is bright enough and does not differ much in flux density with this source in K-band, so we will use 3C48 for bandpass calibration and benefit from the known spectral slope of this standard flux calibrator in determining the bandpass.

f48-opt-Kpoint
Figure 48: The Reference pointing scan using the complex gain calibrator source.

 

Start-up Overhead

Before the first calibrator outside the loop, we need to add a pointing scan. And because we are switching from 8-bit to 3-bit after the pointing, another setup scan is required. We add two scans of the calibrator: the first scan should be a pointing scan with scan mode selected to be Interferometric Pointing and an initial duration of 3 minutes (may need to be increased later) using the X-band pointing resource from the NRAO defaults catalog and the pointing target (which fortunately again is J0741+3112). Furthermore, make sure there is no "Apply Last" selected in the reference pointing column. The second scan, which is another setup scan after the 8-bit resource pointing scan but before the 3-bit K-band gain calibration scan, should apply pointing and use the K-band resource with a setup intent for a duration of 30 seconds (see Figure 49).

f49-opt-Krequant
Figure 49: The basic science scan sequence starting with the pointing scan and the requantizer setup scan before the gain calibration scan highlighted; the parameters for this scan are shown in the main editing window (right-hand side).

Figure 49 shows the science part of the observation. Now we should allow for the start-up overhead, flux density, and bandpass calibration. The flux/bandpass calibration is best placed at the start or at the end of the observation as it typically requires long slews away from the region of interest. Here we chose to do flux density calibration at the start of the observation using 3C48. Other examples are given in the extensive documentation throughout the OPT manual and the Guide to Observing with the VLA. The sequence to follow from the start of the observation to the first science scans is as follows:

Default Resource Setup at the StartScan TimeIntents and Notes
L-band setup on first source (3C48) 3 minutes setup scan (set 8-bit attenuator levels)
K-band setup on first source (3C48) 1 minute setup scan (set 3-bit attenuator levels)
X-band pointing setup on first source (3C48) 1 minute setup scan (set 8-bit attenuator levels)
Flux and Bandpass Calibrator ScansScan TimeIntents and Notes
X-band reference pointing on 3C48 7 minutes Interferometric Pointing scan mode; Start-up includes initial setup scans plus the first calibrator or reference pointing scan to allow 10-12 minutes in total duration. When starting with reference pointing, a 12 minute (minimum) start-up is the best approach.
K-band 3-bit setup on 3C48 30 seconds setup scan (setting requantizer levels) when switching from 8-bit (X point) to 3-bit (K), apply last (reference pointing)
K-band bandpass and flux on 3C48 a few (3) minutes flux density scale, bandpass, complex gain, apply last (reference pointing)
L-band bandpass and flux on 3C48 a few (3) minutes flux density scale, bandpass, complex gain, apply last (reference pointing)
Science scans to follow    science target bracketed by the complex gain calibrator

 If the four flux density and bandpass scans are moved to the end of the observation, the resource setup at the start would be using the pointing source and an additional pointing scan on that source for 7 minutes. Examples can be found in the OPT Manual and the Guide to Observing with the VLA. The sequence in the table above is shown in Figure 50.

f50-opt-startup
Figure 50: The resource setup and flux and bandpass scan overhead at the start of the observation, before the basic science scans.

Now that the observing structure is in place, click on the SB name to enter the scheduling parameter within the Information tab. In the proposal the LST range for this source to be above 25 degrees elevation was calculated to be between 02h16m and 18h51m. The earliest LST start time for this observation is 02h16m, but as this block is 2.5 hours long, the latest LST start time is 16h31m (which follows from the latest LST allowed, 18h51m, minus 2h30m for the length of the block). Enter this in the Information tab for the LST start range (02:15 and 16:30). Finally, select the weather conditions for the highest frequency band used in the SB (K-band), i.e., 7 m/s for wind and 10.0 degrees for the API upper limits to start this SB (see Figure 51).

f51-opt-info
Figure 51: The dynamic scheduling starting conditions for this SB for LST start range and weather for the highest frequency band in the SB. The set up scans for slew to area of sky and attenuation set up are the scans in the red block; reference pointing scans and flux density / bandpass calibration scans are in the blue block; complex gain calibration and science target scans are in the green block.

 

Fine Tuning

Click on the Reports tab to see how this SB would perform for the average start time (12:52:30, or any other time selected within the assumed LST start range on the Reports tab). The window at the bottom will show an error and the scan listing (third table down the main window) will show many red rows (see Figure 52).

f52-opt-reperror
Figure 52: The red colored error messages in the window at the bottom and the red scan rows in the main window.

For the first scan, and the setup scans to follow, this is normal and nothing to worry about; but it should be clear that for the assumed starting time of 12:52 LST that 3C48 has already set below the horizon. The Guide to Observing with the VLA shows that 3C48 is only up until about 08:33 LST for the minimum elevation limit (10 degrees), and will be below the anticipated 25 degrees elevation limit after about 07h LST. Return to the Information tab and use 06:40 as the latest LST start (to account for the first 20 minutes of time spent on 3C48), and go back to the Reports tab. Another error appears, this time on the pointing scan which requires 2:30 minutes on source after any necessary slewing. We allocated a duration of 3 minutes, but more than 30 seconds is spent on slewing from 3C48 to the first source (see the red scan row in Figure 53).

f53-opt-reperror2
Figure 53: The reference pointing scan on J0741+3312 is too short to perform the antenna pointing.

In this particular case the software chooses the shortest way, clockwise (CW), to go from Az 280° (where 3C48 is at the LST start time) to the rising gain calibrator at Az 440°. The antenna array should be directed counter-clockwise (CCW) to make this slew happen from Az 280° CCW to Az 80°(=440°). To achieve this, select CCW wrap for the relevant (8th) scan (see Figure 54) on the gain calibrator and add about 5 minutes to the total time to allow for a 200° slew at 40° a minute (the Azimuth slew rate of the telescopes). These errors are now gone in the Reports tab, and ample time is left for the pointing scan.

f54-opt-reperror3
Figure 54: Selecting the wrap for a scan.

Try other LST start times in the start range, watch for errors on particular scans, and fix them if they appear. Make sure to stay within the allocated time (2h30m) and modify the schedule, if necessary, to achieve this criteria. In this case the total time is 2:45 so 15 minutes must be cut, for example, by taking 40 seconds off the K-band target scan and 20 seconds off the K-band calibration scan (one minute per loop, 15 loops). Other choices are also possible as long as you can still detect your calibrator and perform other calibration scans. Go back to the Reports tab and play around with LST start times and look for errors, e.g., short on source times (less than 20 to 40 seconds). Finally, go to the Validation tab, validate and submit (Figure 55).

f55-opt-submit
Figure 55: The Validation tab.

If you have problems that you cannot fix yourself or with help of a colleague, please feel free to ask the NRAO Hepdesk.